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What is SPRY Gopher?
SPRY Gopher is a networked information search and retrieval application for the Internet.    
With SPRY Gopher, you can access many different types of information regardless of the 
information's location, using whatever tools (ftp, telnet, a GIF viewer, etc.) are appropriate to
the task.
SPRY Gopher displays and retrieves information from Internet Gopher Servers, sites on the 
Internet that are set up with easy to navigate Internet information, organized by topic.    
Gopher Servers are usually set up as menus; SPRY Gopher is set up with an easy-to-use tree-
based screen that makes it even easier to navigate up and down these lists of information.
SPRY Gopher was designed as a unique interface for navigating, viewing and retrieving 
resources on Internet Gopher Servers.
Gopher Servers index a wide variety of information in a relatively organized fashion.    
Information is grouped on a Gopher Server by category, not by location, and the 
organization of the information is done by the Gopher Server administrator.    Much of the 
information you find on a Gopher Server may actually be located elsewhere on the Internet; 
that is why we refer to Gopher as a tool for "navigating" the Internet.
A Gopher Server might list a category of items, like Electronic music, and include text files,
sound files, music programs for IBM and Macintosh, and a search database for song titles.    
These items might be located at different sites around the world.    But when you use gopher,
you don't need to know where these resources are actually located to use them (although 
this information is available to you).
Gopher clients are programs that can connect to Gopher Servers and display and retrieve 
the information they hold, using whatever tools are appropriate.    SPRY Gopher is a Gopher 
client that is an invaluable resource for opening, viewing, and retrieving information because
it provides a flexible interface that you can adapt to your own information needs.    You can 
traverse Gopher Servers using a familiar Windows File Manager style tree structure, and click
on the resources you see with your mouse.    With Gopher, you can effortlessly search for 
gopher information, connect to other hosts (using a telnet application, if you have one 
available), and transfer files to your PC or directly open and view them with your existing 
Windows applications.
Gopher also includes customization features, allowing you to create many custom windows 
with just the resources you want to use.



Starting SPRY Gopher
You can start SPRY Gopher by clicking on the SPRY Gopher icon.    SPRY Gopher will start 
connecting to a pre-defined Gopher Server.    You can set Gopher to connect to a different 
Gopher Server on startup, if you prefer, or start Gopher without attaching to a Gopher 
Server.    
When Gopher connects to the Gopher Server, you will see the Gopher Console, which will list
information about the Gopher Server you connected to.
Currently, there are two panes on the screen, the browser pane, on the left, and the list 
pane, on the right.    These panes will initially list the same information, but as you browse 
with Gopher, you will primarily use the browser pane to browse Gopher menus, whereas the 
list pane will list the information (resources) you find.
Click Toolbar/Status Bar for information on the Toolbar and Status Bar on the SPRY Gopher 
Console.



Toolbar/Status Bar
The Gopher Console displays a Toolbar and Status Bar, described below.
The Toolbar at the top of the console contains Toolbar buttons that serve as shortcuts for 
some of these menu items.    The Toolbar style can be changed between Picture & Text, 
Picture only, and Text only by choosing Toolbar Style in the Options menu.    
The Status Bar at the bottom of the Console displays concise help for Gopher menu items 
and Toolbar buttons and will display status messages such as the location of the Gopher 
resource you are currently accessing.
Both the Toolbar and the Status Bar can be shown or hidden by checking or unchecking 
Show Status Bar and Show Toolbar in the Options menu.    The Toolbar and Status Bar 
will be displayed if checked.
Note: Depending on where the Gopher Server is you are connecting to, and how busy the time of day, there may 

be a delay initially connecting to the Server.    Please be patient while connecting.    A timeout message 
should appear if no connection can be made. 



Toolbar Style
The <Toolbar Style> dialog allows you to change the appearance of the Toolbar shortcut 
buttons.    You can choose between three different displays:    
Both Picture & Text, Picture only, or Text only.    
Click the appropriate radio button to select the Toolbar style, and click OK.    The Toolbar will 
change immediately.



Connecting to Gopher Servers
There are three ways you can use Gopher to connect to Gopher Servers.      When you initially
start Gopher, it is set to connect to a "default" Gopher Server, the first option described 
below.
1) Connect to a default Gopher Server on startup.
Gopher is initially set to automatically connect you to a gopher server that was set up as the
Default Gopher Server.    You can change what server Gopher starts with, or set Gopher to 
start with no Gopher Server, by using Startup Settings in the Options menu.    See 
Gopher Startup Options for more information.
2) Connect to the default Gopher Server after startup.
You can connect to the Default Gopher Server (described above) at any time by choosing 
Connect to Default Server in the Connections menu.    This might be useful if you closed 
the connection to your Default Server, and want to reconnect.
3) Connect to a new Gopher Server after startup.
To connect to a new Gopher Server at any time, choose Connect to New Server from the 
Connections menu, or click the New button on the Toolbar.    You will be asked to specify 
the Title (optional), Host (the location), Port, and Selector for that Server.    For information 
on filling out these fields, see Gopher Startup Options.
You can use this command if you want to open a second (or third, or fourth...) Gopher Server
after you've connected.    You may also use this command if you started Gopher without 
automatically connecting to a Gopher Server. 
4) Open a saved Gopher File
Gopher allows you to create customized Gopher windows containing Gopher resources you 
want to frequently access; you can save these windows to files and open them at any time.   
You can also use this method to store the locations of several different Gopher Servers. You 
use the Create New Window command in the Window men to create windows, and the 
Save or Save As command in the File menu to save the windows to Gopher Files.
Once you have created and saved Gopher windows, you can open them to start the 
connection to those resources.    You do this by choosing Open from the File menu and 
specifying the name of the Gopher File you saved.    See Customizing Gopher for further 
information.



Gopher Startup Options
Gopher includes a pre-defined Gopher Server, which will allow you to navigate the Internet, 
and reach almost all other Gopher Servers.    You can startup Gopher with other Gopher 
Servers, if you wish.    Note that for the most part, they all draw from the same pool of 
information; most Gopher Servers have doorways to other Gopher Servers all over the world.
You can, if you wish, setup other Gopher Servers to connect to automatically (or start 
Gopher without connecting to any Gopher Servers).    Choose Startup Settings from the 
Gopher Options menu.    You will see the Startup Settings dialog.    Fill out the dialog with 
information about your default and backup Gopher Servers.
Click Startup Settings for more information about how to fill out this dialog.



Startup Settings
There are two Gopher Servers defined in this dialog.    The server defined as Default Server
will be started automatically when Gopher starts, if Connect to Default Server on Startup is 
checked.    The server defined as Backup Server is optional; if you define a backup server, 
Gopher will automatically try to connect to that server when the Default Server is not 
available.
You must fill out the fields below for the Default and, if desired, backup gopher server.    After
specifying these settings, click OK.    The options will be saved automatically; the next time 
you start Gopher, it will try to connect to the Server you defined.
Title (Required) A name you choose for the Gopher Server.    This can be any name you 

choose.
Host (Required) The fully qualified domain name (such as gopher.interserv.net) for the 

Gopher Server.
Port The port for the Gopher Server; usually 70.    Do not change this option 

unless you know it to be different from 70.
Selector This is an advanced setting similar to a DOS Pathname which can be 

used to indicate the location of a resource on the host.    In most cases, 
you will not need to change this field.

Type The Type setting (also known as the URL, or Uniform Resource Locator),
is a setting used throughout Gopher (in Gopher, and other gopher 
programs) to define the type of a Gopher resource.    For a Gopher 
Server, this value should be 1 (Gopher Subdirectory).    See 
Understanding Gopher Resources for a listing of Type settings.

Connect to Default Server at Startup
If this option is checked, Gopher will automatically try to connect to the Default Server 
when Gopher is started.    If the Default Server is not available, Gopher will try to connect to 
the Backup Server.    
You will see an error message if Gopher cannot connect to the Default Server; then, Gopher 
will connect to the Backup Server.    You will be able to tell which Server you've connected to 
by the root, or main, directory shown in the browser window.
If this option is not checked, Gopher will start without making any connections.



Gopher Menu Commands
File menu 
Edit menu 
Connections menu 
Options menu 
Window menu 



File menu
Open 
Save 
Save As 
Associate 
Exit 



Edit menu
Cut 
Copy 
Paste 
Add New Item 



Connections menu
Connect to New Server 
Properties 
Connect to Default Server 
Stop Process 



Options menu
Font 
Startup Settings 
Toolbar Style 
Preferences 
Show Status Bar 
Show Toolbar 



Window menu
Create New Window 
Cascade 
Tile 
Arrange Icons 
Close 
Close All 
Rename 



Rename
The <Rename> dialog lets you specify a new name for your currently selected Gopher 
window.    Specify any name (of any length) you like, and press [Enter].    The window will be 
renamed immediately.



Navigating Through Gopher
When you first start Gopher, the Gopher Console displays the main Gopher Server directory 
and subdirectories.    Unlike other Gopher applications, SPRY Gopher uses a tree structure to 
display Gopher information; other gopher applications show this information in "menu" 
format.
The two parts of the screen you see are known as the browser pane (on the left), and the 
list pane (on the righ)..    The Gopher Console will show you the name of the main Gopher 
directory in the browser pane, and the list pane contains a list of the subdirectories under 
that directory.    You can immediately click on the directory folders to open them and find the 
information they contain.
Gopher will supply you with a great many resources.    Resources in Gopher can be text files, 
applications, sound and graphic files, telnet sites, search databases, and more.    You might 
find information such as sports scores, reference books, magazine articles, pictures of 
helicopters, and fragments of movie dialogue.    You can access many of these resources just 
by doubleclicking on them.
For more information on Gopher Resources, click Understanding Gopher Resources.



Understanding Gopher Resources
It is helpful to know something about the different kinds of resources that are found on 
Gopher and how they work.    The icons next to resource names in the Gopher Console will 
show you what the resources represent.    Most of the resources will be items you can view, 
retrieve, or use.    Gopher will allow you to access most of the resources you see just by 
doubleclicking on them.
Gopher automatically knows how to access many of these resources, but you may have to 
set up additional associations in Gopher before you will be able to access them.    
The primary resource you will see is a Gopher Subdirectory.    Clicking on a subdirectory will 
display other subdirectories and/or lists of resources.
The Gopher Resource Table shows the icons you will see when using Gopher and the 
resources they represent (along with the Resource Type, a field used by Gopher to identify 
the resource), and describes the actions that occur when you access them. 
Note: The Resource Type is also known as the URL, or uniform resource locator.    Gopher reads this information 

from the Gopher Server to recognize the resource.



Gopher Resource Table
Resources in Gopher
RESOURCE (TYPE) ACTION

Text File (0) The file will be opened by the text editor or word processor you have 
specified using the Associate command.    You can then use your 
editor to save, print, or change the file.

Macintosh file (4) Gopher will transfer the file to your PC; you will be prompted for a 
filename to save the file under.

DOS file (5) Gopher will transfer the file to your PC; you will be prompted for a 
filename to save the file under.

UUencoded file (6) Gopher will transfer the file to your PC; you will be prompted for a 
filename to save the file under. 

Note: UUencoded files are binary files encapsulated in an ASCII header and footer; they must be decoded using a 
uuencode/uudecode program.

Search (7) This indicates that you can search for the type of information specified 
in the name of this resource.    Clicking on this item will bring up a 
search box.    

Note: There are different ways to search for information that are dependent on the resource.    A common search 
method is simply to type keywords in the box that appears.    For instance, on a search item called Network-
Related Articles you might type the keywords IPX and LAN.    This would bring up all of the articles indexed 
in that search database that contain those words.

Telnet (8) Clicking on this icon will start a Telnet session to connect you to the 
host which has the resource specified, using the Telnet program you 
specified with the Associate command.    If you do not have a Telnet 
program, you will not be able to access these resources.

Note: Gopher may provide a login ID and password for the Telnet resource you are accessing; type that ID, and 
any password (often you are asked to specify your e-mail address as a password).

Binary (9) (Non-specific binary file).    Gopher will transfer this file to your PC; you 
will be prompted for a filename to save the file under.

Image (I) If you specified a graphics application using the Associate command, 
the image file will be opened by that application.    If you do not have a 
graphics application, the image will be stored in a temporary file.

GIF (g) If you specified a GIF viewer application using the Associate 
command, the GIF file will be opened by that application.    If you do not
have a GIF viewer application, the image will be stored in a temporary 
file.

tn3270 (T) Clicking on this icon will start a tn3270 session to connect you to the 
host which has the resource specified, using the tn3270 program you 
specified with the Associate command.    If you do not have a tn3270 
program, you will not be able to access these resources.

Sound (s) If you specified a sound player application (like Microsoft Windows 
built-in Sound Recorder) using the Associate command, the sound 
file will be opened by that application.    If you do not have a sound 
application, the image will be stored in a temporary file.



Server Error (3) This icon usually indicates that the data object is not recognized by 
Gopher.    The Server may be unavailable, or the resource may be 
incorrectly identified by the server.



Stop Process
You can click the Stop button on the Toolbar, or choose Stop Process in the Connections 
menu at any time to stop the current Gopher process.



Using Associations in Gopher
Gopher lets you access many different kinds of resources.    Most of the resources are files 
(text files, applications, graphics files), that you will want to view or use; others are 
resources like Telnet and tn3270 that will connect you to other systems.    Gopher deals 
differently with these different types of resources.    
For instance, when you click on a graphics file, the file will be stored in a temporary file 
(perhaps called TEMP.IMG).    You will not notice this process, it is automatic.    Then, if you 
have associated up a graphics application to view the image with (such as Windows 
Paintbrush), that application will be started, and will try to open the image.
Gopher allows you to access certain types of resources immediately, by setting up 
application associations for those resource types.    This means that when you doubleclick on
a resource, Gopher will automatically try to access that resource using the application you 
specify.    For instance, you might want to access Telnet resources using a Telnet program, or 
access text files using Microsoft Word for Windows; you could set up these associations using
the Associations command.
You can associate files using the Associate command in the File menu, or click the 
Associate button on the Toolbar.    The <Associate> dialog will appear.
Click File Associations for information on how to specify associations in Gopher.
Binary Files
Binary files are automatically transferred to your PC.    You will be prompted to identify a 
location and name for the file.
Text Files, GIF files, Image Files, Sound Files
Gopher saves these files to temporary files, and will try to open them with the application 
associated with them.
Telnet and tn3270 nodes 
Gopher will try to access these nodes using the application associated with them.    



File Associations
The <Associate> dialog lets you view and change the associations for the different types of 
resources in Gopher (see Understanding Gopher Resources for more information on 
resources).    When you select a type of file in the Files of Type: dialog, you will see the 
current association appear in the Associate with: field.    
You can change an association by changing the Associate with value to the application you 
desire.    Type the path and filename for the application in the Associate with: field, or browse
files and directories on your PC by clicking the Browse button--a Windows file search dialog 
will appear; when you have found the directory and file you want to use, click OK. 
When you have specified all the changes you want to make to the associations dialog, click 
OK.
If you correctly associated the resource, when you next doubleclick on that type of resource, 
the associated application will be started and will try to open that resource.
When you open a resource using an associated application, you are actually active in the 
other application, and can use that application as you would normally.    Closing that 
application will not close Gopher.



Locating a Resource Using Properties
Whenever you open a subdirectory, the Status Bar will display the location of that 
subdirectory (in other words, the location of that Gopher Server).    This is a quick way for 
you to know where the resource you are looking for is located.    However, sometimes you 
may want to know more information about where a resource is located--perhaps to access it 
using another application.
You can choose Properties in the Connections menu, or click the Properties buttton to 
examine information about a Gopher resource.
The fields in the <Properties> dialog are described below.
The Title is the name the Gopher Server assigned to the resource.
The Host is the location of this resource.    This hostname is useful information as it indicates
where you could reach this resource using other applications, if necessary.
The Port is the port of this resource; this may vary depending on the Server the resource 
resides on.
The Selector is the exact location of the resource on the host.    Like the host, this item may 
help you locate the resource if you connect to the host using another application.
The Type is the Resource Type ID of this resource.    Refer to the Gopher Resource Table for 
the list of resource type IDs and what they mean.



Customizing SPRY Gopher
There are several ways you can customize Gopher.    Gopher allows you to create new 
windows, containing just the resources you want to view.
For example, you may find a category called "What's New on the Internet" that you will want
to check regularly.    However, to locate it, you customarily have to navigate through a vast 
maze of Gopher subdirectories to find it.    Gopher lets you create a new window with "What's
New on the Internet" as its title.    This means that you can then open that window directly, 
making a connection to that resource as if it were a Gopher Server you connected to directly.
You can customize Gopher in the following ways:

Create a new window, with the subdirectory you have highlighted as the main directory of that 
window.

Rename a Gopher window.

Save a window to a Gopher File, so that you can quickly retrieve it and open only the resources 
that you want.

Open a saved Gopher File to quickly access resources.

Cut, copy and paste Gopher resources from one window to another.

Add a new resource to any Gopher window.



Create New Window
Before you can use the Create New Window command, however, the subdirectory you 
want to create the window from must be in the list pane on the right hand side of the 
screen.    You can do this by clicking on the "parent" topic of the target subdirectory, so that 
your topic moves to the list pane.    In the example provided, you would have to click on 
News, Entertainment,Weather, Sports to get the topic over to the list pane.    Then you could 
select the "Professional Sports Schedule" subdirectory and choose Create New Window 
from the Window menu, or click the Create button on the Toolbar.    A new window would 
be created.
Depending on how Gopher is set up, this new window may appear to "replace" your current 
screen; however, it didn't.    Your other windows are still open--just choose Tile or Cascade 
from the Window menu to show all the windows at once.    Or switch between windows by 
selecting the window titles from the titles shown in the Window menu.



Working with Multiple Windows
When you have multiple windows open, there are several ways you can choose to manage 
them:

Choose Cascade from the Window menu to cascade the windows

Choose Tile from the Window menu to tile the window.

You can minimize windows that you want to work with later by clicking on the Minimize (down) 
arrow in the upper right hand corner of the window.    If you have several windows open and 
minimized, and want to arrange them neatly on yoru desktop, you can choose Arrange All in the 
Window menu.

You can close your currently highlighted Gopher Window by choosing Close from the Window 
menu, or close all Gopher Windows by choosing Close All.



Renaming a Gopher Window
You can, if you wish, rename a Gopher window by selecting the window and choosing the 
Rename Window command from the Window menu.    Specify a new name for the 
window, and click OK.



Saving a window to a Gopher File
Once you have created a new window in Gopher, you should save it to a Gopher File, so that 
you can open it at any time.    You do this by selecting the window (if you have several open) 
and choosing Save  (or Save As, if you have already saved this window and want to save it 
under a different name) from the File menu to save it.



Save/Save As
The <Save> or <Save As> dialog lets you specify the name of the file you want to save the 
current Gopher window to; an extension of .GGG is suggested for this file.
Specify a name and location for the file, and click OK.    The Gopher window will be saved to 
the filename you specified.
You can open this file at any time using the Open command.



Opening a Gopher File
You can open a saved Gopher File at any time by choosing Open in the File menu or clicking
the Open button.    You will see a Windows file search box asking you to specify the name of 
the Gopher File to open (it will look for files with extension .GGG by default).    Specify the 
filename and click OK.    When you open the Gopher File, Gopher will connect to the main 
directory in that window and displays the resources under that directory.    (Note: if the 
resources change, you will see the new resources).    You can open as many saved windows 
as you like.
Click Creating Gopher Files for information on creating customized Gopher Files containing 
Gopher Resources.



Cutting, Copying, and Pasting Resources Between 
Windows
You can remove any resources from a Gopher window (cut), or copy resources from them to 
paste in other windows, as described below.
Removing a resource from a Gopher window
After highlighting the resource you want to remove, choose the Cut command from the Edit
menu, or click Ctrl-X.    The resource will be removed from the window, and the resource 
information will be copied to the Windows Clipboard, so that you can paste them in other 
windows, if desired.
Copying resources from a Gopher window
After highlighting the resource you want to copy, choose the Copy command from the Edit 
menu, or click Ctrl-C.    The resource information will be copied to the Windows Clipboard, so
that you can paste them in other windows, if desired.
Pasting a resource into a Gopher window
You must have either cut or copied a Gopher resource in order to paste it into another 
window.    Highlight the place in the window where you want to paste the copied or cut 
resource--the resource will be pasted just underneath the resource you highlighted--and 
choose Paste from the Edit menu, or click Ctrl-V.    The new resource will be pasted into the
window right below the currently highlighted resource.
You can use these features to create a custom window with your favorite resources and then 
save the Gopher session containing that menu and open it whenever you want to access 
those resources.    Do not forget to save the window, so your new menu or changes to 
resources will be preserved.



Adding a New Resource to a Window
You can also add new resource items to a window, if you know the location of the resources.  
Select a resource in the window--the new resource item will appear at the end of the current 
Gopher window--and choose Add New Item from the Edit menu.
To set up a new item, specify the item's Title, Host, Type, and Selector, as described below.

Title (Required) A name you choose for the resource.    This can be any name you 
choose.

Host (Required) The fully qualified domain name (such as gopher.interserv.net) of the 
host where the resource is found.

Port (Optional) The port for the resource (usually 70).    Leave this option blank unless 
you know the specific port for this resource.

Selector (Optional) This is an advanced setting similar to a DOS Pathname which can be 
used to indicate the location of a resource on the host.    If you know 
the selector for the resource, type it here.    The syntax of the selector 
is N/Selectorinfo, where N is the Type ID of the resource. (Ex:    
1/Booklist)

Type (Optional) Type is a setting used throughout Gopher (in SPRY Gopher, and other 
gopher programs) to define the type ID of a Gopher resource.    For a 
Gopher Server, this value should be 1 (Gopher Subdirectory).    See the 
Gopher Resources Table for a listing of Type IDs.

Click OK to add the resource item, it will be added to the window just below the currently 
highlighted resource.



Font
The <Font> dialog lets you can change the font, font style and size that Gopher uses to 
display text in Gopher Windows.    Changing the fonts in Gopher will change the text 
appearance in the current window only, and the screen window will resize to maintain the 
current view.    (To change the font in another window, you must choose Font again with that
window highlighted).    
The Font dialog box displays a standard Windows font selection screen.    Choose the font, 
font style and font size you want for the current session and click OK.    The font changes will 
take effect only in the current session unless you have Save Settings on Exit checked.



Setting Gopher Preferences
Gopher allows you to change how long Gopher waits for a connection and the number of 
times it tries to connect, using the <Preferences> dialog (accessed from the    Options 
menu).    You can also control whether the Toolbar and Status Bar options are displayed and 
what font is used in Gopher windows.    The <Preferences> options are described below.
Timeout length defines how long Gopher will wait for the connection to complete when you
try to access a Gopher resource. The default is 30 seconds.
Maximum Number of Connection Tries defines how many times Gopher will try to open 
a connection to a resource.    The default is 20 times.
In other words, with the defaults, Gopher would try to connect 20 times, waiting 30 seconds 
each time.    
You can also use this dialog to show the Gopher Toolbar and Status Bar.



Finding Information in Gopher
There is no formal method for finding information in Gopher; a utility named Veronica does 
exist to allow you to search for information throughout "gopherspace" (all the gopher 
servers everywhere).    You will find this utility on many Gopher Servers.
Veronica is used just like other search utilities throughout Gopher; just type the text that you
hope to find in a resource title on Gopher.    Veronica will locate it for you.



Exiting Gopher
You can exit Gopher by choosing Exit from the File menu.    You can also doubleclick on the 
Windows System Menu to exit Gopher.
 




